Is HGE slow?

All information about Magic Particles: news, question, comments, etc.

Is HGE slow?

Postby barney » Wed Aug 19, 2009 7:42 am

Hi there, fellow developers again!
I'm using Magic Particles with HGE but it seems to be sometimes, really slow. Like, when i create a system about 200-300 particles the fps drops from 450 to 200 and when i create about, over 1000 particles the fps drops dramaticly, to 40-50 fps and over 2000 it drops to 15 - 20 fps. Is there a way to solve this problem? Is it HGE? Thanks!
barney
 
Posts: 11
Joined: Mon Jul 13, 2009 3:55 pm

Re: Is HGE slow?

Postby Odin_KG » Wed Aug 19, 2009 12:47 pm

matrix_fps.jpg
FPS for HGE
matrix_fps.jpg (302.58 KiB) Viewed 22756 times


HGE-wrapper (Delphi) shows FPS=102 for 6481 particles. (AMD 2800 64+/ GF 6600GT)

Is there a way to solve this problem?

I think you use debug-mode.
User avatar
Odin_KG
Administrator
Administrator
 
Posts: 249
Joined: Sat May 09, 2009 10:53 pm

Re: Is HGE slow?

Postby barney » Wed Aug 19, 2009 3:00 pm

No I'm using the release version. Ah, sorry, forgot to mention my hardware. I'm on a laptop 1.43 Ghz Dual Core but my graphics adapter is not so good, i think that should be the problem. Thanks :)
barney
 
Posts: 11
Joined: Mon Jul 13, 2009 3:55 pm

Re: Is HGE slow?

Postby Odin_KG » Wed Aug 19, 2009 3:51 pm

I'm on a laptop 1.43 Ghz Dual Core but my graphics adapter is not so good, i think that should be the problem.

Yes. I think the same. But my graphics addapter is 4 years old :) .
User avatar
Odin_KG
Administrator
Administrator
 
Posts: 249
Joined: Sat May 09, 2009 10:53 pm

Re: Is HGE slow?

Postby barney » Wed Aug 19, 2009 4:44 pm

Haha :) Considering I have a 2 year old and very cheap laptop, those results are also quite possible :)
barney
 
Posts: 11
Joined: Mon Jul 13, 2009 3:55 pm

Re: Is HGE slow?

Postby Odin_KG » Wed Aug 19, 2009 5:06 pm

I think your graphic addapter was made by SYS. It is very slow addapter which takes the memory from motherboard.
User avatar
Odin_KG
Administrator
Administrator
 
Posts: 249
Joined: Sat May 09, 2009 10:53 pm

Re: Is HGE slow?

Postby barney » Wed Aug 19, 2009 7:00 pm

Let's see what device manager says:
Mobile Intel 965 Express Chipset Family - I think it has 256 mb shared. No doubt, it is a slow graphics card, but I'm happy with my Team Fortress 2(in dx 8 mode ) :lol:
barney
 
Posts: 11
Joined: Mon Jul 13, 2009 3:55 pm


Return to Magic Particles

Who is online

Users browsing this forum: No registered users and 13 guests

cron